avreal/linux and libftd2xx.so.1.0.0 64-bit

На початку грудня FTDI зробила нам невеличкий подаруночок — випустила версію 1.0.0 бібліотеки libftd2xx.so (попередня версія була 0.4.16). Щось там, мабуть, дуже сильно покращили, але 64-бітна версія avreal/linux перестала працювати. В чому причина, явні помилки десь, чи «просто неохайний» код, через який вилізли проблеми в avreal, доведеться ще розбиратися. Поки-що я на сторінці download виклав архіви попередньої версії libftd2xx, з якою avreal працює стабільно.


Більше про це тут: «Подаруночок від FTDI»

5 Responses to “avreal/linux and libftd2xx.so.1.0.0 64-bit”

  1. smartly says:

    может всё таки нуеё?

    http://www.intra2net.com/en/developer/libftdi/documentation/

    правда, с libftdi будут аналогичные проблемы. Дело в том, что libusb разделилась на две ветки – stable и legacy, libfdti пока ещё использует legacy, процесс портирования на stable ещё не закончен.

    • ReAl says:

      Та я про це іноді думаю. Тобто, про необхідність розібратися нарешті з libftdi.

      До речі, якщо вже зайшла мова про libftdi.
      Я влітку розбирався нарешті з OpenOCD, так, якщо я не помилився, версії 4.0 та 5.0 і через libftdi теж зносять ttyUSB1 на ttyUSB0 при роботі через ft2232.

Leave a Reply

[flagcounter image]